Failures and Delays running Student Demand Forecasting analyses

Incident Report for Ad Astra

Identified

Our Engineering team has identified a performance bottleneck that is causing analysis results to sporadically fail. We are working on an immediate fix for the bottleneck and investigating other performance improvements.
Posted Dec 03, 2025 - 16:54 CST

Investigating

We have identified an increase in the number of failed Student Demand Forecasting analyses since around November 20th. Affected mascots will see stale results for forecasted demand and recommendations. Our Engineering team is investigating the root cause of the analysis failures.
Posted Dec 03, 2025 - 11:33 CST
This incident affects: Ad Astra (adastra.live) (Dashboard Visualizations & Reporting, Data-Informed Scheduling, Student-Centered Scheduling, Integrated Planning).