Annual Scheduling degraded load times

Incident Report for Ad Astra

Resolved

This incident has been resolved.
Posted May 05, 2026 - 16:36 CDT

Update

We are continuing to monitor for any further issues.
Posted May 05, 2026 - 16:09 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 05, 2026 - 16:09 CDT

Identified

We've identified a performance issue with one of our databases. We are currently implementing several mitigation plans. Response times have improved slightly as we continue to work toward a full resolution.
Posted May 05, 2026 - 14:26 CDT

Investigating

Annual Scheduling is currently experiencing slower than expected load times. Our team is actively investigating and working urgently to improve performance. Thank you for your patience.
Posted May 05, 2026 - 11:10 CDT
This incident affected: Ad Astra (adastra.live) (Essential Scheduling).