Ad Astra Apps: Align recommendations
Incident Report for Ad Astra
Resolved
This incident has been resolved.
Posted Aug 18, 2023 - 18:04 CDT
Identified
We've identified an issue loading Recommendations in Align. This does not impact Astra Schedule. While we implement a fix, you may workaround the issue by clearing your browser cache.
Posted Aug 18, 2023 - 13:22 CDT
This incident affected: Ad Astra (adastra.live) (Applications).